TLS Version 1.0 Retired

HMRC has stopped support for TLS 1.0 and we recommend that software applications use TLS 1.2 or higher.

From 1st October 2019 this change will be applied to the Sandbox and Production (Live) environments for Restful APIs (Base URLs - https://test-api.service.hmrc.gov.uk and https://api.service.hmrc.gov.uk ). The following notification has been added to the Authorisation section of the Developer hub :

‘HMRC APIs are only accessible over Transport Layer Security (TLS, that is https://). We require that new applications support TLS 1.2 or higher to avoid known weaknesses in previous versions. You should upgrade your existing applications by 1 October 2019 when we will remove support for previous versions.’

A further notification will be issued to confirm when we will make this change for our XML APIs but we recommend that you do not wait for this and that you consider changing now any of your software applications that may be impacted.

If you have any questions in respect of this notification, please contact the SDSTeam

Back to news

We use cookies on this site to improve your experience. By continuing to browse the site you are agreeing to our use of cookies. You will only see this message once. Find out more

close